vendredi 25 septembre 2015

"Flex users will need to download the original AIR SDK without the new compiler."?

I am confused about upgrading AIR for use with Flex 4.6 (I am using 4.6 because "design mode" isn't supported in Flash Build with later versions).

I successfully overlaid AIR 19 on a copy of the Flex 4.6 SDK. Some projects were fine but others were not. For example the <mx:Alert/> is not supported (apparently) in AIR 19 by default and I resolved that by linking to the mx.swf

In another project I am finding that <s:ConstraintRow/> is not supported. Searching around I found this question: Could not resolve <s:Sequence> to a component implementation after adding AIR 3.6

So, ok – I see the note I missed before on the AIR 19 page: "Flex users will need to download the original AIR SDK without the new compiler."

My Questions:

  • What is the "original" AIR SDK? What version is that? Is this just poor wording and means "the latest AIR without the AS compiler 2.0" Or is Flex deadended for AIR upgrades?
  • What is the deal with AIR version numbers? I see both "AIR 19" and "AIR 3.4" etc. which seems like two different numbering schemes.

Aucun commentaire:

Enregistrer un commentaire